您的位置:首页 > 其它

PAT甲级 1096. Consecutive Factors (20)

2017-01-20 16:38 369 查看
Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.
Input Specification:
Each input file contains one test case, which gives the integer N (1<N<231).
Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.
Sample Input:
630
Sample Output:
3
5*6*7


题目大意
给你一个数N(1~2^31),让你求它的因式中数量最多的连续整数。如果数量相同则让求出的饮食最小。
注意这里是因式而不是N的因子。

题目解析
暴力寻找到i*i<=n即可。

坑点:针对最后一个测试样例,循环的时候i*i可能会爆int所以在循环时候的i设置成long long即可。
是个好题,针对了打代码的习惯。
#include <cstdio>
#include <cmath>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cstdlib>
#include <climits>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

#define ll long long
const int MAXN = 100000 + 5;
const int MAXM = 10000 + 5;
const int INF = 0x7f7f7f7f;
const int dir[][2] = {0,1,1,0,0,-1,-1,0};
template <class XSD> inline XSD f_min(XSD a, XSD b) { if (a > b) a = b; return a; }
template <class XSD> inline XSD f_max(XSD a, XSD b) { if (a < b) a = b; return a; }
template <class XSD> inline XSD f_abs(XSD a) { return a<0?(-a):a; }
int n;
bool vis[MAXN];
void Getdata(){
}
void Solve(){
int start, max_=0;
for(ll i=2; i*i<=n; i++){///这里的i设置成long long防止最后一个case超时
int num=0, t=n;
for(int j=i; j<=t; j++){
if(t%j==0) num++, t/=j;
else break;
}
if(num>max_){
start=i;
max_=num;
}
}
if(max_){
printf("%d\n", max_);
for(int i=start; i<start+max_; i++)
printf("%d%c", i, i==(start+max_-1)?'\n':'*');
}
else printf("1\n%d\n", n);

}
int main(){
while(~scanf("%d", &n)){
Getdata();
Solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: