您的位置:首页 > 产品设计 > UI/UE

【POJ 2524 Ubiquitous Religions】+ 并查集

2017-01-19 17:48 483 查看
Ubiquitous Religions

Time Limit: 5000MS Memory Limit: 65536K

Total Submissions: 33063 Accepted: 16019

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9

1 2

1 3

1 4

1 5

1 6

1 7

1 8

1 9

1 10

10 4

2 3

4 5

4 8

5 8

0 0

Sample Output

Case 1: 1

Case 2: 7

题意 : N 个人,M组关系,每组给出a,b,a与b为朋友,有多少个朋友圈

思路 : 所有关系的并在一起,求有多少个集合

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
int f[50010],vis[50010];
int bc(int x){
int p = x;
while(x != f[x]) // 寻找父节点
x = f[x];
while(p != x){ // 路径压缩
int t = f[p];
f[p] = x;
p = t;
}
return x;
}
int main()
{
int N,M,a,b,nl = 0;
while(scanf("%d %d",&N,&M) != EOF && (N || M)){
for(int i = 1 ; i <= N ; i++)
f[i] = i;
while(M--){
scanf("%d %d",&a,&b);
int fa = bc(a),fb = bc(b);
f[fa] = fb;
}
memset(vis,0,sizeof(vis));
int ans = 0;
for(int i = 1 ; i <= N ; i++){
int fi = bc(i);
if(!vis[fi]){
vis[fi] = 1;
ans++;
}
}
printf("Case %d: %d\n",++nl,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj