您的位置:首页 > 其它

ZCMU-训练赛-Primary Arithmetic

2017-01-19 15:40 204 查看

Problem C: Problem C: Primary Arithmetic

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 101  Solved: 32

[Submit][Status][Web
Board]

Description

Problem C: Primary Arithmetic

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number
of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0. For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers,
in the format shown below.

Input

Output

Sample Input

123 456

555 555

123 594

0 0

Sample Output

No carry operation.

3 carry operations.

1 carry operation.

【解析】
这道题就是叫你求a+b需要进位的次数,比如说5+5为10了,所以要进位,这样进位的个数是1,样例2总共进位了三次,所
以输出3,这里需要注意的是如果进位1次,输出格式中最后的operation是没有s的。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
int n,m;
int i,j,count1,p,q,len,jinwei;
while(~scanf("%d%d",&n,&m))
{
int a[101]={0};
int b[101]={0};
p=0,q=0;
count1=0;
if(n==0&&m==0)
break;
while(n!=0)
{
a[p++]=n%10;
n=n/10;
}
while(m!=0)
{
b[q++]=m%10;
m=m/10;
}
len=max(p,q);
jinwei=0;
for(i=0;i<len;i++)
{
a[i]=a[i]+b[i]+jinwei;
if(a[i]>=10)
{
a[i]=a[i]-10;
jinwei=1;
count1++;
}
}
if(count1==0)
{
printf("No carry operation.\n");
}
else if(count1>1)
{
printf("%d carry operations.\n",count1);
}
else if(count1==1)
{
printf("%d carry operation.\n",count1);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: