您的位置:首页 > 其它

1001. A+B Format (20)

2017-01-18 23:54 696 查看
主页

题目集

基本信息

题目列表

提交列表

排名

帮助

1001. A+B Format (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

提交代码

解题步骤:

1.求和

2.处理符号

3.分离数字–入栈

4.出栈–按位的位置补逗号

提示:别忘了处理和为0的情况

实例代码

#include<iostream>
#include<vector>
#include<cstdio>
using namespace std;
int main()
{
int a, b, sum;
cin >> a >> b;
sum = a + b;
if (sum <0)
{
cout << '-';
sum = -sum;
}
int count = 0;
vector<int> s;
if (sum == 0)
{
count++;
s.push_back(sum);
}
while (sum != 0)
{
count++;//数字个数
s.push_back(sum % 10);
sum /= 10;
}
for (int i = count - 1; i >= 0; i--)
{
if ((i - 2) % 3 == 0 && i != count-1)
{
cout << ',' << s[i];
}
else cout << s[i];
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: