您的位置:首页 > 编程语言 > C语言/C++

PAT甲级1050

2017-01-18 23:40 447 查看


1050. String Subtraction (20)

时间限制

10 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from
S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104.
It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.
Sample Input:
They are students.
aeiou

Sample Output:
Thy r stdnts.


#include<cstdio>
#include<iostream>
#include<string.h>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
bool hashtable[128];
fill(hashtable, hashtable + 128, true);//bool hashtable[128] ={true};不会全部填充
char s1[10010], s2[10010];
//getline(cin, s1);
//getline(cin, s2);用这个会超时
gets_s(s1); gets_s(s2);//提交时改为gets即可
int len1 = strlen(s1);
int len2 = strlen(s2);
for (int i = 0; i < len2; i++)
{
hashtable[s2[i]] = false;
}
for (int i = 0; i <len1; i++)
{
if (hashtable[s1[i]])
cout << s1[i];
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息