您的位置:首页 > 其它

poj1018 Communication System dp

2017-01-16 20:10 369 查看
题目链接:http://poj.org/problem?id=1018

Communication System

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27892 Accepted: 9946
Description
We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers
differ in their maximum bandwidths and prices.

By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100),
the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same
line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.
Output
Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input
1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output
0.649


题意:

某公司要建立一套通信系统,该通信系统需要n种设备,而每种设备分别可以有m1、m2、m3、...、mn个厂家提供生产,而每个厂家生产的同种设备都会存在两个方面的差别:带宽bandwidths 和 价格prices。

现在每种设备都各需要1个,考虑到性价比问题,要求所挑选出来的n件设备,要使得B/P最大。
其中B为这n件设备的带宽的最小值,P为这n件设备的总价。

思路:动态规划

dp[i][j] 表示选择了前 i 个宽带其容量为 j 的最小费用

状态转移方程:转移方程 :dp[i][j]=min(dp[i][j],dp[i-1][k]+p);

动态规划的题型还是不熟练,需要看其他人的代码才能敲出来

代码:

#define _CRT_SBCURE_MO_DEPRECATE
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<functional>
using namespace std;
const int maxn = 10000 + 10;
const int INF = 0x3f3f3f3f;

int T, n, num;
int dp[maxn][maxn];

int main() {
scanf("%d", &T);
while (T--) {
scanf("%d", &n);
for (int i = 0; i < maxn; i++) {
for (int j = 0; j < maxn; j++)
dp[i][j] = INF;
}
//dp过程
for (int i = 1; i <= n; i++) {
scanf("%d", &num);
for (int j = 1; j <= num; j++) {
int b, p;
scanf("%d %d", &b, &p);
if (i == 1)
dp[1][b] = min(dp[1][b], p);
else {
for (int k = 0; k < maxn; k++) {
if (dp[i - 1][k] != INF) {
if (k < b)//注意k和b的选择
dp[i][k] = min(dp[i][k], dp[i - 1][k] + p);
else
dp[i][b] = min(dp[i][b], dp[i - 1][k] + p);
}
}
}
}
}
double ans = 0;
for (int i = 0; i < maxn; i++) {
if (dp
[i] != INF) {
double k = (double)i / dp
[i];
ans = max(ans, k);
}
}
printf("%.3lf\n", ans);
}
system("pasue");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息