您的位置:首页 > 其它

hdu 1087 Super Jumping! Jumping! Jumping! (最大递增子段和)

2017-01-15 22:23 288 查看
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 

Your task is to output the maximum value according to the given chessmen list. 

InputInput contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N 

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 

A test case starting with 0 terminates the input and this test case is not to be processed. 

OutputFor each case, print the maximum according to rules, and one line one case. 

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0


Sample Output
4
10
3
题目大意: 给你一个数列,让你找一个递增的子列,并且,这个子列的和是最大的,其实就是求最大递增子段和。
题目分析:做完这一题之后,才明白状态转移方程的重要意义,刚开始就是因为状态转移方程有一个误区,所以导致思路一直进展不下去,后来把状态转移方程搞出来了,是:sum[j]=max{sum[i]}+a[j]; 其中,0<=i<=j,a[i]<a[j]   .#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 1005;
int a[maxn],sum[maxn];
const int inf = 999999999;
int main(){
int t,n,k,s;
while((scanf("%d",&n))!=EOF){
if(n==0)
break;
memset(a,0,sizeof(a));
memset(sum,0,sizeof(sum));
for(int i=0;i<n;i++){
scanf("%d",&a[i]);
sum[i]=a[i];
for(int j=0;j<i;j++){
if(a[j]<a[i])
sum[i]=max(sum[i],sum[j]+a[i]);
}
}
int max=-inf;
for(int i=0;i<n;i++){
if(max<sum[i])
max=sum[i];
}
printf("%d\n",max);
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐