您的位置:首页 > 其它

挑战程序设计竞赛 POJ 2431 贪心+优先队列

2017-01-15 19:31 351 查看
Expedition

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13825 Accepted: 3917
Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P
Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10

Sample Output
2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
Source

USACO 2005 U S Open Gold

/*
* poj 2431
* author : mazciwong
* creat on: 2016-1-15
*/

/*
加油站,优先队列
*/

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <functional> //greater
#include <algorithm>
using namespace std;
typedef long long ll;
const int maxn = 10000 + 5;
int n; //加油站数
int l, p; //距离,已有油量
struct point {
int x;
int v;
}s[maxn];//油站地点和油量
bool cmp(point s1, point s2)
{
return s1.x < s2.x;
}
void solve()
{
//把最终的终点也当作油站
s
.x = l;
s
.v = 0;
n++;
//按距离从小到大排
sort(s, s + n, cmp);
priority_queue<int> pque; //值大先取出来

//ans:加油次数, pos:现在的位置, tank:油箱的油
int ans = 0, pos = 0, tank = p;

for (int i = 0; i < n; i++)
{
//下来要前进的距离
int d = s[i].x - pos;

//加油加到够用
while (tank - d < 0)
{
if (pque.empty())
{
puts("-1");
return;
}
tank += pque.top();
pque.pop();
ans++;
}
tank -= d;
pos = s[i].x;
pque.push(s[i].v);
}
printf("%d\n", ans);
}
int main()
{
scanf("%d", &n);
for (int i = 0; i < n; i++)
scanf("%d%d", &s[i].x, &s[i].v);
scanf("%d%d", &l, &p);
for (int i = 0; i < n; i++)
s[i].x = l - s[i].x;
solve();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: