您的位置:首页 > 其它

2016 小灶1 F (POJ2635)

2017-01-15 10:43 281 查看
题目:

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes,
and are believed to be secure because there is no known method for factoring such a product effectively.

What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users
keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

InputThe input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10
100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.OutputFor each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.Sample Input
143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output
GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31


题意:一个数(k)为两个质数的乘积,求这个数能否被小于(是小于,并不是小于等于)L的质数除尽。

方法:首先注意到L的范围很大,应先用筛法求出一定范围内的素数(这个范围要稍大于10^6,因为第一遍做刚好求到10^6,提交就WA了,开大一点就过了。。。估计是后台数据的问题),第二点:K的值较大,达到了1e+100。明显超出了long long的范围。这里我们可以采用万进制。即将K(例如K=abcdefghi转化成K=abcd*100000+efghi)余数就是((abcd%L)*100000+efghi)%L,注意,这个余数会超出int,建议使用long long。

源代码://By Sean Chen
#include <iostream>
#include <cstdio>
#include <cstring>
#define Max 1040000
using namespace std;
int notprime[Max];
int prime[Max],cntprime;
int power[5]={1,10,100,1000,10000};
void findprime() //筛法求素数
{
notprime[2]=0;
for (int i=2;i<Max;i++)
{
if (!notprime[i])
{
cntprime++;
prime[cntprime]=i; //用prime数组存储所有素数
for (int j=2;j*i<Max;j++)
{
notprime[i*j]=1;
}
}
}
//cout<<cntprime<<endl;
return ;
}
int k[25],cnt,pos,l;
char c[105];
int main()
{
findprime();
/*for (int i=1;i<=89;i++)
cout<<prime[i]<<' ';
cout<<endl;*/
scanf("%s%d",c,&l);
while (l)
{
cnt=0;pos=0;
k[0]=0;
for (int i=strlen(c)-1;i>=0;i--) //以字符串形式读入大数字K,并转化成万进制。
{
k[pos]+=(c[i]-'0')*power[cnt];
cnt++;
if (cnt==5)
{
pos++;
k[pos]=0;
cnt=0;
}
}
//cout<<k[pos]<<endl;
if(!cnt)
pos--;
/*for (int i=pos;i>=0;i--)
cout<<k[i]<<' ';*/
int flag=1;
long long mod; //mod用来存储余数
for (int i=1;i<=cntprime && prime[i]<l && flag;i++)
{
mod=0;
for (int j=pos;j>=0;j--)
{
mod=(mod*100000+k[j])%prime[i];
}
//cout<<prime[i]<<' '<<mod<<endl;
if (!mod) //k%L==0
{
flag=0;
printf("BAD %d\n",prime[i]);
}
}
if (flag) printf("GOOD\n");
scanf("%s%d",c,&l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: