您的位置:首页 > 其它

【HDU 1020】Encoding 水

2017-01-15 08:56 399 查看

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 43139    Accepted Submission(s): 19057

[align=left]Problem Description[/align]
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

[align=left]Input[/align]
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

 

[align=left]Output[/align]
For each test case, output the encoded string in a line.

 

[align=left]Sample Input[/align]

2
ABC
ABBCCC

 

[align=left]Sample Output[/align]

ABC
A2B3C

 

题意:

把这个只存在大写A到Z的字符串换种方式输出。

如果某字符只有一个,则直接输出它,如果连着两个或以上,就输出它连续的数量和这个字符本身。

需要稍微注意一点。

如果字符串是ABBCBB这种,输出就是A2BC2B,而不是A4BC。

#include<stdio.h>
#include<string.h>
int main()
{
int T,d,i,n,j;
char a[101000];
scanf("%d",&T);
getchar();
while(T--)
{
gets(a);
n=strlen(a);
for(i=0;i<n;i++)
{
d=0;
for(j=i+1;;j++)
{
if(a[i]==a[j])d++;//若字符连续相等则计数增加
else break;//若不同跳出
}
if(d==0)printf("%c",a[i]);
else if(d>=1)printf("%d%c",d+1,a[i]);
i=i+d;//跳过重复的字符
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: