您的位置:首页 > 其它

2016 小灶练习1 A题 (HDU1034)

2017-01-14 22:09 330 查看
题目:

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right.
Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number
is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6

36

2

2

2

2

2

11

22

20

18

16

14

12

10

8

6

4

2

4

2

4

6

8

0

Sample Output

15 14

17 22

4 8

 

题意就是小朋友有偶数颗糖,每次给右边的人一般的糖,若剩下的糖为奇数,就给这个小朋友一颗糖,问多少轮后每个小朋友手上的糖数相同

算法:模拟。

源代码:

//By Sean Chen
#include <iostream>
#include <cstdio>
using namespace std;
int a[1005],ans;
int f(int n) //判断每个小朋友的糖数是否相等
{
for(int i=0;i<n-1;i++)
if(a[i]!=a[i+1])
return 1;
return 0;
}

int main()
{
int n;
scanf("%d",&n);
while(n)
{
ans=0;
for(int i=0;i<n;i++)
cin>>a[i];
while(f(n)) // 模拟每一轮小朋友的糖数变化
{
ans++;
int temp=a[n-1]/2;
for(int i=n-1;i>0;i--)
{
a[i]=a[i]/2+a[i-1]/2;
if(a[i]%2)
a[i]++;
}
a[0]=a[0]/2+temp;
if(a[0]%2)
a[0]++;
}
cout<<ans<<" "<<a[0]<<endl;
scanf("%d",&n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: