您的位置:首页 > 其它

POJ 1265Area(几何应用)

2017-01-14 16:43 483 查看

Area

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6426 Accepted: 2815
Description
Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance
robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted.
Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight
walls are used. Figure 1 shows the course of a robot around an example area.



Figure 1: Example area.

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula
he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that
simple formula for you, so your first task is to find the formula yourself.

Input
The first line contains the number of scenarios.

For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair
means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself
except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100
units.

Output
The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point.
Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.
Sample Input
2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output
Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

Source
题意:多边形的边经过了多少点?多边形内部有多少点?多边形的面积是多少?
题解:面积最简单是所有相邻两点向量的叉积。经历了多少点是两点的最大公约数。内部有多少点是皮克定理

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>

using namespace std;

struct node
{
int x;
int y;
}a[110110];

int gcd(int x, int y)
{
return y?gcd(y, x%y):x;
}

int main( )
{
int k, n, i, h = 1;
scanf("%d", &k);
while(k--)
{
scanf("%d", &n);
for(i = 0; i < n; i++)
{
scanf("%d %d", &a[i].x, &a[i].y);
if(i!=0)
{
a[i].x += a[i-1].x;
a[i].y += a[i-1].y;
}
}
a
.x = 0;
a
.y = 0;
int s = 0;
for(i = 0; i < n; i++)//一条处于点阵上的线段包含的点为x,y的最大公约数
{
s += gcd(abs(a[i].x-a[(i+1)%n].x) , abs(a[i].y-a[(i+1)%n].y));
}
int area = 0;
for(i = 0; i < n; i++)//相邻两点的及原点构成的三角形的面积为两向量的叉积
{
area += a[i].x*a[i+1].y - a[i].y*a[i+1].x;
}
if(area<0)
area = -area;
int s2 = (area+2-s)/2;
printf("Scenario #%d:\n", h++);
printf("%d %d %.1f\n",  s2, s, area/2.0);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: