您的位置:首页 > 其它

HDU-1251 统计难题 (Trie)

2017-01-13 11:53 316 查看
题目:

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input

banana

band

bee

absolute

acm

ba

b

band

abc

Sample Output

2

3

1

0

思路:

Trie字典树模板题,我用了两种做法,一种是指针写的,一种是汪神传授的数组模拟,数组一开始过不去问学长说数组要开大一点。

数组模拟Trie有一点我想了很久才明白,就是ch[1][x]只记录每个串第一个位置的下标,相当于一个入口,如果要标记或者计数是不考虑它的。

这题提交要用C++,G++会MLE。

链式Trie代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<set>

using namespace std;

typedef struct TrieNode{
int cnt;
bool flag;
TrieNode *next[26];
TrieNode(){
cnt = 0;
flag = false;
memset(next, 0, sizeof(next));
}
}TrieNode, *Trie;

TrieNode *InitTrieNode(){
TrieNode *p = new TrieNode;
return p;
}

void InsertNode(Trie root, char *word){
Trie p = root;
char *ch = word;
int id;
while(*ch){
id = *ch - 'a';
if (p->next[id] == NULL)
p->next[id] = InitTrieNode();
p = p->next[id];
p->cnt++;
++ch;
}
p->flag = true;
}

int TrieSearch(Trie root, char *word){
Trie p = root;
char *ch = word;
int id;
bool ans = false;
while(*ch){
id = *ch - 'a';
if (p->next[id] == NULL)
return 0;
p = p->next[id];
++ch;
}
return p->cnt;
}

int main()
{
Trie root = InitTrieNode();
char ch[15], c;
while(gets(ch), ch[0]){
InsertNode(root, ch);
}
while(scanf("%s", &ch) != EOF){
printf("%d\n", TrieSearch(root, ch));
}

return 0;
}


数组模拟Trie代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<set>

using namespace std;
int ch[1100000][26], cnt[1100000], fir[26], num = 1;

void Insert(char *word){
int now = 1, len = strlen(word), id;
for (int i = 0; i < len; ++i){
id = word[i] - 'a';
if (ch[now][id]) now = ch[now][id];
else now = ch[now][id] = ++num;
++cnt[now];
}
}

int Search(char *pre){
int len = strlen(pre), now = 1, id;
for (int i = 0; i < len; ++i){
id = pre[i] - 'a';
if (ch[now][id]) now = ch[now][id];
else return 0;
}
return cnt[now];
}

int main()
{
char word[20], c;
while(gets(word), word[0]){
Insert(word);
}
while(scanf("%s", &word) != EOF){
printf("%d\n", Search(word));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Trie