您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表四:有序链表的归并

2017-01-13 08:28 197 查看


Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。


Input

第一行输入M与N的值; 

第二行依次输入M个有序的整数;

第三行依次输入N个有序的整数。


Output

输出合并后的单链表所包含的M+N个有序的整数。


Example Input

6 5
1 23 26 45 66 99
14 21 28 50 100



Example Output

1 14 21 23 26 28 45 50 66 99 100



Hint

不得使用数组!


Author

#include<stdio.h>

#include<stdlib.h>

struct node

{

    int data;

    struct node *next;

};

int main()

{

    int m, n, i;

    struct node *head1, *p1, *tail1, *head2, *tail2, *p2;

    scanf("%d%d", &n, &m);

    head1 = (struct node *) malloc (sizeof (struct node ));

    head1 -&g
4000
t; next = 0;

    tail1 = head1;

    head2 = (struct node *) malloc (sizeof (struct node ));

    head2 -> next = 0;

    tail2 = head2;

    for(i = 0; i < n; i++)

    {

        p1 = (struct node *) malloc (sizeof (struct node ));

        scanf("%d", &p1 -> data);

        p1 -> next = NULL;

        tail1 -> next = p1;

        tail1 = p1;

    }

    for(i = 0; i < m; i++)

    {

        p2 = (struct node *) malloc (sizeof (struct node ));

        scanf("%d", &p2 -> data);

        p2 -> next = NULL;

        tail2 -> next = p2;

        tail2 = p2;

    }

    p1 = head1 -> next;

    p2 = head2 -> next;

    tail1 = head1;

    free(head2);

    while(p1 && p2)

    {

        if(p1 -> data < p2 -> data)

        {

            tail1 -> next = p1;

            tail1 = p1;

            p1 = p1 -> next;

        }

        else

        {

            tail1 -> next = p2;

            tail1 = p2;

            p2 = p2 -> next;

        }

    }

    if(p1)

    {

        tail1 -> next = p1;

    }

    else

    {

        tail1 -> next = p2;

    }

    p1 = head1 -> next;

    while(p1 != NULL)

    {

        if(p1 -> next == NULL)

            printf("%d\n", p1 -> data);

        else

            printf("%d ", p1 -> data);

        p1 = p1 -> next;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: