您的位置:首页 > 其它

POJ - 3280 Cheapest Palindrome

2017-01-12 21:00 435 查看
Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of
N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤
cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so
it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input
Line 1: Two space-separated integers: N and
M

Line 2: This line contains exactly M characters which constitute the initial ID string

Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output
900

Hint
If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350
= 900, which is the minimum.

题意:给你一个由n种小写字母组成长度为m的字符串
          给出每种字符 增加的代价  和 减小的代价
          求出把给定字符串变为回文串的最小代价
思路:这个题首先要注意
          1  代价 对于一个回文串 增加一个字符变为回文串 和 减小串中的一个字符变为回文串 等效  所以可以预处理字符的最小代价
          2  对于一个回文区间    只有增加两个字符串 或者 减小两个字符 才能形成一个回文串
             所以dp【i】【j】为一个长度减一回文的子区间 +增加一个字符后    加减1个字符的代价
ACcode:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int dp[2010][2010];
int cost[30];
char s[2010];
int n,m;
int main(){
while(scanf("%d%d",&m,&n)!=EOF){
scanf("%s",s+1);
char name[10];
int up ,dowmn;
for(int i=1;i<=m;i++){
scanf("%s %d %d",name,&up,&dowmn);
cost[name[0]-'a']=min(up,dowmn);
}
for(int i=1;i<=n;i++) dp[i][i]=0;
for(int len=1;len<n;len++){
for(int i=1;i+len<=n;i++){
int j=i+len;
dp[i][j]=0x7fffffff;
if(s[i] == s[j])  dp[i][j]=dp[i+1][j-1];  //s[i] == s[j] 说明可以在dp[i+1][j-1]  前后增加字符 代价为0
dp[i][j]=min(dp[i][j],dp[i+1][j]+cost[s[i]-'a']);  //dp[i+1][j]+cost[s[i]-'a']  说明【i+1】【j】区间前面加入字符是【i】 求变回文区间的代价
dp[i][j]=min(dp[i][j],dp[i][j-1]+cost[s[j]-'a']);  //同理
}
}
printf("%d\n",dp[1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: