您的位置:首页 > 其它

HDU-1165-Eddy's research II(递推 打表 找规律)

2017-01-12 16:55 721 查看
Eddy’s research II

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4686 Accepted Submission(s): 1709

Problem Description

As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:



Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).

Input

Each line of the input will have two integers, namely m, n, where 0 < m < =3.

Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.

Input is terminated by end of file.

Output

For each value of m,n, print out the value of A(m,n).

Sample Input

1 3

2 4

Sample Output

5

11

题意:根据给出的公式,求出对应的A(M,N)

注意M=1||2时,N<=100w

M==3时,N<=24

根据公式深搜打个表,递推公式就出来了

打表代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int DFS(int m,int n)
{
if(m==0)
return n+1;
if(m>0&&n==0)
return DFS(m-1,1);
return DFS(m-1,DFS(m,n-1));
}
int main()
{
int m,n;
while(scanf("%d%d",&m,&n)!=EOF)
{
printf("%d\n",DFS(m,n));
}
return 0;
}


最终代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int DP[4][1000005];
int main()
{
DP[1][0]=2;
DP[2][0]=3;
DP[3][0]=5;
for(int i=1;i<=2;i++)
for(int j=1;j<=1000000;j++)
DP[i][j]=DP[i][j-1]+i;
for(int j=1;j<=24;j++)
DP[3][j]=DP[3][j-1]*2+3;
int m,n;
while(scanf("%d%d",&m,&n)!=EOF)
printf("%d\n",DP[m]
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: