您的位置:首页 > 产品设计 > UI/UE

【STL】poj2259 Team Queue (队列+map的应用)

2017-01-10 20:21 363 查看
Team Queue

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4597 Accepted: 1589
Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them.
If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue.
Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers
in the range 0 - 999999. A team may consist of up to 1000 elements. 

Finally, a list of commands follows. There are three different kinds of commands: 
ENQUEUE x - enter element x into the team queue 

DEQUEUE - process the first element and remove it from the queue 

STOP - end of test case

The input will be terminated by a value of 0 for t. 

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.
Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 

Sample Input
2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output
Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001


题意:有t个小组 每组n个元素的编号,有以下三种操作:

ENQUEUE  x  将x放入队列中(要放在x所在小组元素的后面,若该小组还未有元素放入队列就放在队列后面)

DEQUEUE 输出队首元素的编号

STOP 结束
思路:用数组记录(map会超时,感谢评论区提醒)各个元素所在的小组,用两个队列,一个数组队列存各小组中加入队列的元素编号,另一个队列存加入队列小组的编号
code:

#include<stdio.h>
#include<string.h>
#include<map>
#include<iostream>
#include<string>
#include<queue>
#define N 1005
using namespace std;
bool vis
;//标记小组是否已经入队
int mat[1000000];
int main()
{
int T,n,a,t=0;
while(~scanf("%d",&T)&&T)
{
queue<int>team
;//team[i]表示第i个小组 ,用于存各个小组加入队列的元素
queue<int>q;//组队列,记录组号
memset(vis,false,sizeof(vis));
memset(mat,0,sizeof(mat));
for(int i=0; i<T; i++)
{
scanf("%d",&n);
while(n--)
{
scanf("%d",&a);
mat[a]=i;
}
}
printf("Scenario #%d\n",++t);
char s[20];
while(~scanf("%s",s))
{
if(s[0]=='S')
{
break;
}
if(s[0]=='E')
{
int number,b;
scanf("%d",&number);
b=mat[number];
team[b].push(number);
if(vis[b]==false)//该小组还未有元素入队,将该小组入队
{
q.push(b);
vis[b]=true;
}
}
else if(s[0]=='D')
{
int ans=q.front();
printf("%d\n",team[ans].front());
team[ans].pop();
if(team[ans].empty())//如果该组元素已为空 删除该组
{
vis[ans]=false;
q.pop();
}
}
}
printf("\n");
}
return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: