您的位置:首页 > 其它

hdu Humble Numbers(打表)

2017-01-10 19:48 155 查看
Humble Numbers

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence

 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

 

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

 

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

题意:若一个数中的所有的素因子只有2,3,5,7,则这个数为humble数,求第n个humble数
思路:若一个数是humble数,则它的2,3,5,7倍仍然是humble数
a[i]为第i个humble数,则a[i]=min(min(min(2*a[b2],3*a[b3]),5*a[b5]),7*a[b7]),b2,b3,b5,b7在不断地更新
代码:
#include<stdio.h>
#define min(a,b) (a<b?a:b)
#define LL   long long int
LL a[6000];
void humble_number()
{
a[1]=1;
int b2=1,b3=1,b5=1,b7=1;
int ps=1;
while(ps<=5842)
{
int k=min(min(min(2*a[b2],3*a[b3]),5*a[b5]),7*a[b7]);
if(k==2*a[b2])
b2++;
if(k==3*a[b3])
b3++;
if(k==5*a[b5])
b5++;
if(k==7*a[b7])
b7++;
a[++ps]=k;//注意这里和上面,避免了重复
}
}
int main()
{
humble_number();
int n;
while(~scanf("%d",&n),n)
{
if(n%100==11||n%100==12||n%100==13)//注意这里
printf("The %dth humble number is %d.\n",n,a
);
else if(n%10==1)
printf("The %dst humble number is %d.\n",n,a
);
else if(n%10==2)
printf("The %dnd humble number is %d.\n",n,a
);
else if(n%10==3)
printf("The %drd humble number is %d.\n",n,a
);
else
printf("The %dth humble number is %d.\n",n,a
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: