您的位置:首页 > 其它

AtCoder Beginner Contest 051 ABCD题

2017-01-08 22:53 471 查看

A - Haiku

Time limit : 2sec / Memory limit : 256MBScore : 100 points

Problem Statement

As a New Year's gift, Dolphin received a string s of length 19.
The string s has the following format:
[five lowercase English letters],[seven lowercase English letters],[five lowercase English letters]
.
Dolphin wants to convert the comma-separated string s into a space-separated string.
Write a program to perform the conversion for him.

Constraints

The length of s is 19.The sixth and fourteenth characters in s are
,
.The other characters in s are lowercase English letters.

Input

The input is given from Standard Input in the following format:
s

Output

Print the string after the conversion.

Sample Input 1

Copy
happy,newyear,enjoy

Sample Output 1

Copy
happy newyear enjoy

Replace all the commas in
happy,newyear,enjoy
with spaces to obtain
happy newyear enjoy
.

Sample Input 2

Copy
haiku,atcoder,tasks

Sample Output 2

Copy
haiku atcoder tasks

Sample Input 3

Copy
abcde,fghihgf,edcba

Sample Output 3

Copy
abcde fghihgf edcba

题意:根据样列猜题意
解法:模拟
#include<bits/stdc++.h>
using namespace std;
int main()
{
string s;
cin>>s;
for(int i=0;i<s.length();i++)
{
if(s[i]!=',')
{
cout<<s[i];
}
else
{
cout<<" ";
}
}
}

B - Sum of Three Integers

Time limit : 2sec / Memory limit : 256MBScore : 200 points

Problem Statement

You are given two integers K and S.
Three variable X,Y and Z takes integer values satisfying 0≤X,Y,Z≤K.
How many different assignments of values to X,Y and Z are there such that X+Y+Z=S?

Constraints

2≤K≤2500
0≤S≤3KK and S are integers.

Input

The input is given from Standard Input in the following format:
K S

Output

Print the number of the triples of X,Y and Z that satisfy the condition.

Sample Input 1

Copy
2 2

Sample Output 1

Copy
6

There are six triples of X,Y and Z that satisfy the condition:X=0,Y=0,Z=2X=0,Y=2,Z=0
X=2,Y=0,Z=0
X=0,Y=1,Z=1X=1,Y=0,Z=1X=1,Y=1,Z=0

Sample Input 2

Copy
5 15

Sample Output 2

Copy
1

The maximum value of X+Y+Z is 15, achieved by one triple of X,Y and Z.题意:看样列猜题意解法:乍一看感觉是暴力,但不怎么妥当,我这里采用数组保存的方式 500+x+y==s-z记录符合要求的个数
#include<bits/stdc++.h>
using namespace std;
int a[1000000];
int main()
{
int k,s;
cin>>k>>s;
for(int i=0;i<=k;i++)
{
for(int j=0;j<=k;j++)
{
a[5000+i+j]++;
}
}
int sum=0;
for(int i=0;i<=k;i++)
{
int pos=s-i;
if(pos<0)
{
continue;
}
sum+=a[5000+pos];
}
cout<<sum<<endl;
return 0;
}

C - Back and Forth

Time limit : 2sec / Memory limit : 256MBScore : 300 points

Problem Statement

Dolphin resides in two-dimensional Cartesian plane, with the positive x-axis pointing right and the positive y-axis pointing up.
Currently, he is located at the point (sx,sy). In each second, he can move up, down, left or right by a distance of 1.
Here, both the x- and y-coordinates before and after each movement must be integers.
He will first visit the point (tx,ty) where sx<tx and sy<ty, then go back to the point (sx,sy), then visit the point (tx,ty) again, and lastly go back to the point(sx,sy).
Here, during the whole travel, he is not allowed to pass through the same point more than once, except the points (sx,sy) and (tx,ty).
Under this condition, find a shortest path for him.

Constraints

−1000≤sx<tx≤1000
−1000≤sy<ty≤1000
sx,sy,tx and ty are integers.

Input

The input is given from Standard Input in the following format:
sx sy tx ty

Output

Print a string S that represents a shortest path for Dolphin.
The i-th character in S should correspond to his i-th movement.
The directions of the movements should be indicated by the following characters:
U
: Up
D
: Down
L
: Left
R
: RightIf there exist multiple shortest paths under the condition, print any of them.

Sample Input 1

Copy
0 0 1 2

Sample Output 1

Copy
UURDDLLUUURRDRDDDLLU

One possible shortest path is:Going from (sx,sy) to (tx,ty) for the first time: (0,0) → (0,1) → (0,2) → (1,2)Going from (tx,ty) to (sx,sy) for the first time: (1,2) → (1,1) → (1,0) → (0,0)Going from (sx,sy) to (tx,ty) for the second time: (0,0) → (−1,0) → (−1,1) → (−1,2) → (−1,3) → (0,3) → (1,3) → (1,2)Going from (tx,ty) to (sx,sy) for the second time: (1,2) → (2,2) → (2,1) → (2,0) → (2,−1) → (1,−1) → (0,−1) → (0,0)

Sample Input 2

Copy
-2 -2 1 1

Sample Output 2

Copy
UURRURRDDDLLDLLULUUURRURRDDDLLDL
题意:看样列猜题意
解法:根据提示进行模拟
#include<bits/stdc++.h>
using namespace std;
int a[100000];
int main()
{
int sx, sy, tx, ty;
cin >> sx >> sy >> tx >> ty;
for(int i=1;i<=ty-sy;i++)
{
cout<<"U";
}
for(int i=1;i<=tx-sx;i++)
{
cout<<"R";
}
for(int i=1;i<=ty-sy;i++)
{
cout<<"D";
}
for(int i=1;i<=tx-sx;i++)
{
cout<<"L";
}
cout<<"L";
for(int i=0;i<=ty-sy;i++)
{
cout<<"U";
}
cout<<"R";
for(int i=1;i<=tx-sx;i++)
{
cout<<"R";
}
cout<<"D";
cout<<"R";
for(int i=0;i<=ty-sy;i++)
{
cout<<"D";
}
cout<<"L";
for(int i=1;i<=tx-sx;i++)
{
cout<<"L";
}
cout<<"U";
return 0;
}

D - Candidates of No Shortest Paths

Time limit : 2sec / Memory limit : 256MBScore : 400 points

Problem Statement

You are given an undirected connected weighted graph with N vertices and M edges that contains neither self-loops nor double edges.
The i-th (1≤i≤M) edge connects vertex ai and vertex bi with a distance of ci.
Here, a self-loop is an edge where ai=bi(1≤i≤M), and double edges are two edges where (ai,bi)=(aj,bj) or (ai,bi)=(bj,aj)(1≤i<j≤M).
A connected graph is a graph where there is a path between every pair of different vertices.
Find the number of the edges that are not contained in any shortest path between any pair of different vertices.

Constraints

2≤N≤100
N−1≤M≤min(N(N−1)⁄2,1000)1≤ai,bi≤N1≤ci≤1000
ci is an integer.The given graph contains neither self-loops nor double edges.The given graph is connected.

Input

The input is given from Standard Input in the following format:
N M
a1 b1 c1a2 b2 c2
:
aM bM cM

Output

Print the number of the edges in the graph that are not contained in any shortest path between any pair of different vertices.

Sample Input 1

Copy
3 3
1 2 11 3 12 3 3

Sample Output 1

Copy
1

In the given graph, the shortest paths between all pairs of different vertices are as follows:The shortest path from vertex 1 to vertex 2 is: vertex 1 → vertex 2, with the length of 1.The shortest path from vertex 1 to vertex 3 is: vertex 1 → vertex 3, with the length of 1.The shortest path from vertex 2 to vertex 1 is: vertex 2 → vertex 1, with the length of 1.The shortest path from vertex 2 to vertex 3 is: vertex 2 → vertex 1 → vertex 3, with the length of 2.The shortest path from vertex 3 to vertex 1 is: vertex 3 → vertex 1, with the length of 1.The shortest path from vertex 3 to vertex 2 is: vertex 3 → vertex 1 → vertex 2, with the length of 2.Thus, the only edge that is not contained in any shortest path, is the edge of length 3 connecting vertex 2 and vertex 3, hence the output should be 1.

Sample Input 2

Copy
3 2
1 2 12 3 1

Sample Output 2

Copy
0

Every edge is contained in some shortest path between some pair of different vertices.题意:让我们找出不含最短路径的道路有多少条解法:先Floyd跑一次,然后比较原始道路和现在的道路,距离不同就说明最短路径也不经过这条道路,然后加一
#include<bits/stdc++.h>
using namespace std;
long long a[10000][10000];
long long b[10000][10000];
int inf=(1<<31)-1;
int main()
{
int n,m;
cin>>n>>m;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
a[i][j]=inf;
b[i][j]=inf;
}
b[i][i]=0;
a[i][i]=0;
}
for(int i=1;i<=m;i++)
{
long long x,y,z;
cin>>x>>y>>z;
a[x][y]=min(z,a[x][y]);
a[y][x]=min(z,a[y][x]);
b[x][y]=min(z,b[x][y]);
b[y][x]=min(z,b[y][x]);
}
for(int k=1;k<=n;k++)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
a[i][j]=min(a[i][k]+a[k][j],a[i][j]);
//  cout<<a[i][j]<<" "<<i<<" "<<j<<" "<<k<<endl;
}
}
}
int sum=0;
for(int i=1;i<=n;i++)
{
for(int j=1+i;j<=n;j++)
{
if(b[i][j]!=inf&&a[i][j]!=b[i][j])
{
sum++;
//cout<<i<<" "<<j<<endl;
// cout<<a[i][j]<<" "<<b[i][j]<<endl;
}
}
}
cout<<sum<<endl;
// cout<<b[1][2]<<endl;
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: