您的位置:首页 > 其它

poj1426 Find The Multiple dfs搜索答案

2017-01-07 10:13 323 查看
Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28704 Accepted: 11898 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

Source

Dhaka 2002
题意:给你一个n,求一个仅有1、0组成的数(十进制环境)能被n整除。
直接搜索搜索无脑搜搜搜搜

之所以能过是因为这题的数据很温柔。。。優しいです,所有的数不会超出unsigned long long

電車遅いな。。。。。。眠いです

/*
━━━━━┒
┓┏┓┏┓┃μ'sic foever!!
┛┗┛┗┛┃\○/
┓┏┓┏┓┃ /
┛┗┛┗┛┃ノ)
┓┏┓┏┓┃
┛┗┛┗┛┃
┓┏┓┏┓┃
┛┗┛┗┛┃
┓┏┓┏┓┃
┛┗┛┗┛┃
┓┏┓┏┓┃
┃┃┃┃┃┃
┻┻┻┻┻┻
*/
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <queue>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 20;
int n,m;
unsigned long long res;
bool vis;
void dfs(unsigned long long now,int lenth){
if(lenth==19||vis){
return;
}
if(now%n==0){
vis = true;
res = now;
return;
}
dfs(now*10,lenth+1);
dfs(now*10+1,lenth+1);
}
int main(){
while(scanf("%d",&n)&&n){
vis = false;
dfs(1,0);
printf("%llu\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: