您的位置:首页 > 其它

POJ 2456 Aggressive cows__二分

2017-01-06 23:19 417 查看

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

Line 1: Two space-separated integers: N and C

Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

Line 1: One integer: the largest minimum distance

Sample Input

5 3

1

2

8

4

9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

分析

确定n个不同位置的摊位可以放几头牛,要算最大间隔,一个求最大值的问题,用二分法,确认最大、最小间距后不断寻找即可。

实现

#include <iostream>
#include <cstring>
#include <algorithm>
#define MAXN 100010
int a[MAXN];
int n, c;

bool canSolve(long long ans)
{
int lastCowStallIndex = 0, cowCount = 1; //第一头牛肯定放第一个摊位。
for (int i = 1; i < n; i++) {
if (a[i] - a[lastCowStallIndex] >= ans) { //大于给定间距则说明可以再放一头牛。
cowCount++;
lastCowStallIndex = i;
if (cowCount >= c) return true;
}
}
return false;
}

int main()
{
//  freopen("in.txt", "r", stdin);
scanf("%d%d", &n, &c);
for (int i = 0; i < n; i++) {
scanf("%d", &a[i]);
}
if (n <= 0 || c <= 0 || (n < c)) {
printf("%d\n", 0);
return 0;
}
std::sort(a, a + n);
long long l = (n - a[0]) / (c - 1);
l = l < 0 ? 0 : l;
long long r = (a[n - 1] - a[0] / (c - 1));
while (l <= r) {
long long mid = (l + r) >> 1;
canSolve(mid) ? (l = mid + 1) : (r = mid - 1);
}
printf("%lld", l - 1);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: