您的位置:首页 > 其它

Where is the Marble? UVA - 10474

2017-01-02 15:41 501 查看
Raju and Meena love to play with Marbles. They have got a lot of

marbles with numbers written on them. At the beginning, Raju would

place the marbles one after another in ascending order of the numbers

written on them. Then Meena would ask Raju to nd the rst marble

with a certain number. She would count 1…2…3. Raju gets one point

for correct answer, and Meena gets the point if Raju fails. After some

xed number of trials the game ends and the player with maximum

points wins. Today it’s your chance to play as Raju. Being the smart

kid, you’d be taking the favor of a computer. But don’t underestimate

Meena, she had written a program to keep track how much time you’re

taking to give all the answers. So now you have to write a program,

which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins

with 2 integers:

N

the number of marbles and

Q

the number of queries Mina would make. The next

N

lines would contain the numbers written on the

N

marbles. These marble numbers will not come

in any particular order. Following

Q

lines will have

Q

queries. Be assured, none of the input numbers

are greater than 10000 and none of them are negative.

Input is terminated by a test case where

N

= 0 and

Q

= 0.

Output

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether

or not the query number is written upon any of the marbles. The two different formats are described

below:



x

found at

y

', if the  rst marble with number

x

was found at position

y

. Positions are numbered

1

;

2

;:::;N

.




x

not found

‘, if the marble with number

x

is not present.

Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

题意是给你一串数字,然后又让你去找又给你的数字,而且要说明位置,先排序,然后找位置。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
int a[10005];
int main()
{
int n,q,x,y;
int case1=1;
while(scanf("%d %d",&n,&q)&&n&&q)
{
printf("CASE# %d:\n",case1++);
for(int i=0; i<n; i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);
for(int j=1; j<=q; j++)
{
scanf("%d",&x);
int p=lower_bound(a,a+n,x)-a;

if(a[p]==x)
printf("%d found at %d\n",x,p+1);
else
printf("%d not found\n",x);
}
}
return 0;
}


其实这道题本身不难,我想在这里说明的是lower_bound的返回值是一个地址,我这里使用了它减去一个a地址来实现转换成一个值,才能赋值给p,不然会报错,可以参考下面地址中的解释:http://blog.csdn.net/jzwong/article/details/45030291
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  numbers