您的位置:首页 > 运维架构

POJ 1505 Copying Books(誊抄书籍)__二分+贪心

2017-01-01 21:49 330 查看

Description

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 1, 2 … m) that may have different number of pages (p1, p2 … pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, … < bk-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, … pm separated by spaces. All these values are positive and less than 10000000.

Output

For each case, print exactly one line. The line must contain the input succession p1, p2, … pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (‘/’) to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input

2

9 3

100 200 300 400 500 600 700 800 900

5 4

100 100 100 100 100

Sample Output

100 200 300 400 500 / 600 700 / 800 900

100 / 100 / 100 / 100 100

分析

每个人至少抄一本书,检测的边界最小值为最大页数,最大值为总页数,通过二分来定位准确答案,数据应该是排过序的,所以从后往前看在不超过答案页数的情况下形成几堆,算是否超过允许的堆数。

实现

#include <iostream>
#include <cstring>
#define MAXN 510
int a[MAXN];
int m, k;

bool canSolve(long long ans)
{
int heapCount = 1;  //当前堆数目
long long pageCount = 0;  //当前堆页数
for(int i = m - 1; i >= 0; i--) {  //从后向前判断每一本书
if (a[i] + pageCount > ans) {
heapCount++;
pageCount = a[i];
}else {
pageCount += a[i];
}
}
return (heapCount <= k);  //<k表明书少,不能尽量放一堆上,不然不能人守一本。
}

void print(long long ans)
{
int heapCount = 1;
long long pageCount = 0;
bool divider[MAXN];
memset(divider, true, sizeof(divider));
for (int i = m - 1; i >= 0; i--) {
if (k - heapCount == i + 1) {   //剩下的书数等于剩余未分配的抄写员的数目,只能人人分配一本。
break;
}
if (a[i] + pageCount > ans) {
heapCount++;
pageCount = a[i];
}
else {
divider[i] = false;
pageCount += a[i];
}
}
for (int i = 0; i < m - 1; i++){
printf("%d ", a[i]);
if (divider[i]) { printf("/ "); }
}
printf("%d\n", a[m - 1]);
}

int main()
{
//  freopen("in.txt", "r", stdin);
int cases;
scanf("%d", &cases);
while (cases--) {
scanf("%d%d", &m, &k);
memset(a, 0, sizeof(a));
long long l = 0, r = 0, mid = 0;
for(int i = 0; i < m; i++) {
scanf("%d", &a[i]);
r += a[i];
if (l < a[i]) { l = a[i]; }
}
while(l <= r) {
mid = (l + r) >> 1;
canSolve(mid) ? (r = mid - 1) : (l = mid + 1);
}
print(l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: