您的位置:首页 > 产品设计 > UI/UE

区间dp]POJ1141 Brackets Sequence

2016-12-30 23:47 309 查看
POJ 1141 Brackets Sequence

原题链接http://poj.org/problem?id=1141

Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 

2. If S is a regular sequence, then (S) and [S] are both regular sequences. 

3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2
... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.
Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.
Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.
Sample Input
([(]

Sample Output
()[()]


区间dp。。

#include <iostream>
#include <cstring>
using namespace std;
string sub;
int s;
int dp[100][100];
int c[100][100];
void print (int i,int j){
if (i>j) return;
if (i==j){
if (sub[i]=='(' || sub[i]==')') cout << "( ) ";
else cout << "[ ] ";
}
else{
if (c[i][j]>=0){
print(i,c[i][j]);
print(c[i][j]+1,j);
}
else{
if (sub[i]=='('){
cout << "( ";
print (i+1,j-1);
cout << ") ";
}
else{
cout << "[ ";
print (i+1,j-1);
cout << "] ";
}
}
}
}
int main() {
cin >> sub;
s=(int) sub.size();
for (int i=0;i<s;i++) dp[i][i]=1;
for (int i=0;i<s;i++){
for (int j=0;j<s;j++)
c[i][j]=-1;
}

for (int l=1;l<s;l++){
for (int i=0;i+l<s;i++){
int j = i+l;
//断开
c[i][j]=i;
int minimum = dp[i][i]+dp[i+1][j];
int k = i+1;
while (k<j){
if (minimum > dp[i][k]+dp[k+1][j]){
minimum =dp[i][k]+dp[k+1][j];
c[i][j] = k;
}
k++;
}
dp[i][j] = minimum;
if ((sub[i]=='(' && sub[j]==')')||(sub[i]=='['&&sub[j]==']')){
if (dp[i+1][j-1]<minimum){ // 没有断开
dp[i][j] = dp[i+1][j-1];
c[i][j] = -1;
}
}
}
}

print(0,s-1);
cout << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 动态规划 dp