您的位置:首页 > 其它

04-树5 Root of AVL Tree (25分)

2016-12-30 20:57 441 查看
An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the
rotation rules.

AVL树是自平衡二叉搜索树。 在AVL树中,任何节点的两个子树的高度相差最多一个; 如果在任何时候它们相差多于一个,则进行重新平衡以恢复该属性。 图1-4说明了旋转规则。


 






Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

现在给定插入序列,你要给出生成的AVL树的根。


Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le
20≤20)
which is the total number of keys to be inserted. Then NN distinct
integer keys are given in the next line. All the numbers in a line are separated by a space.

每个输入文件包含一个测试用例。 对于每个测试用例,第一行包含一个为正整数的插入的键的总数N(≤20)。 然后在下一行中给出N个不同的整数键。 一行中的所有数字由空格分隔。


Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

对于每个测试用例,在一行中打印生成的AVL树的根。


Sample Input 1:

5
88 70 61 96 120


Sample Output 1:

70


Sample Input 2:

7
88 70 61 96 120 90 65


Sample Output 2:

88


#include <stdio.h>
#include <stdlib.h>

typedef struct AVLNode *AVLTree;
struct AVLNode{
int Data;
AVLTree Left;
AVLTree Right;
int Height;
};

int Max(int a ,int b)
{
return a>b?a:b;
}

int GetHeight(AVLTree T)
{
if(T==NULL)
return 0;
else
return T->Height;
}

AVLTree SingleLeftRotation(AVLTree A)
{
/* 注意:A必须有一个左子结点B */
a409

/* 将A与B做左单旋,更新A与B的高度,返回新的根结点B */
AVLTree B=A->Left;
A->Left=B->Right;
B->Right=A;
A->Height=Max(GetHeight(A->Left),GetHeight(A->Right))+1;
B->Height=Max(GetHeight(B->Left),A->Height)+1;

return B;
}

AVLTree SingleRightRotation(AVLTree A)
{
/* 注意:A必须有一个右子结点B */
/* 将A与B做右单旋,更新A与B的高度,返回新的根结点B */
AVLTree B=A->Right;
A->Right=B->Left;
B->Left=A;
A->Height=Max(GetHeight(A->Left),GetHeight(A->Right))+1;
B->Height=Max(A->Height,GetHeight(B->Right))+1;

return B;
}

AVLTree DoubleLeftRightRotation(AVLTree A)
{
/* 注意:A必须有一个左子结点B,且B必须有一个右子结点C */
/* 将A、B与C做两次单旋,返回新的根结点C */

/* 将B与C做右单旋,C被返回 */
A->Left=SingleRightRotation(A->Left);

/* 将A与C做左单旋,C被返回 */
return SingleLeftRotation(A);
}

AVLTree DoubleRightLeftRotation(AVLTree A)
{
/* 注意:A必须有一个右子结点B,且B必须有一个左子结点C */
/* 将A、B与C做两次单旋,返回新的根结点C */

/* 将B与C做左单旋,C被返回 */
A->Right=SingleLeftRotation(A->Right);

/* 将A与C做右单旋,C被返回 */
return SingleRightRotation(A);

}

AVLTree Insert(AVLTree T,int x)
{ /* 将X插入AVL树T中,并且返回调整后的AVL树 */

if(!T)/* 若插入空树,则新建包含一个结点的树 */
{
T=(AVLTree)malloc(sizeof(struct AVLNode));
T->Data=x;
T->Height=0;
T->Left=T->Right=NULL;
}

else if(x<T->Data)
{
/* 插入T的左子树 */
T->Left=Insert(T->Left,x);
if(GetHeight(T->Left)-GetHeight(T->Right)>1)//左边的高度大于右边,说明新节点插在左边
{
if(x<T->Left->Data)
{
T=SingleLeftRotation(T);//x比T->Left的Data小,LL
}else{
T=DoubleLeftRightRotation(T);//x比T->Left的Data大,LR
}
}
}

else if(x>T->Data)
{
/* 插入T的右子树 */
T->Right=Insert(T->Right,x);
if(GetHeight(T->Left)-GetHeight(T->Right)<-1)
{
if(x>T->Right->Data)
{
T=SingleRightRotation(T);//x比T->Right的Data大,RR
}else{
T=DoubleRightLeftRotation(T);//x比T->Right的Data小,RL
}
}
}

T->Height=Max(GetHeight(T->Left),GetHeight(T->Right))+1;//更新T的高度

return T;
}

int main()
{
int N,num;
AVLTree T=NULL;
scanf("%d",&N);
for(int i=0;i<N;i++)
{
scanf("%d",&num);
T=Insert(T,num);
}
if(T)
{
printf("%d",T->Data);
}
return 0;
}




内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: