您的位置:首页 > 其它

HDU 1312 Red and Black(水题)

2016-12-30 00:52 369 查看

Red and Black

[align=left]Problem Description[/align]
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

 

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

[align=left]Sample Input[/align]

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

[align=left]Sample Output[/align]

45
59
6
13

 
思路:找到起点,四个方向搜索,搜索过的点更改一下;

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
char a[110][110];
int res,n,m;
void dfs(int x,int y)
{
a[x][y]='#';
for(int i=-1;i<=1;i++)
{
for(int j=-1;j<=1;j++)
{
if(abs(i)!=abs(j))
{
int nx=x+i;
int ny=y+j;
if(a[nx][ny]=='.' && 1<=nx<=m && 1<=ny<=n)
{
a[nx][ny]='#';//更改条件
res++;
dfs(nx,ny);
}
}
}
}
}
int main()
{
int i,j,x,y;
while(scanf("%d %d",&n,&m) && (m+n))
{
res=1;
memset(a,0,sizeof(a));
for(i=1;i<=m;i++)
{
getchar();
for(j=1;j<=n;j++)
{
scanf("%c",&a[i][j]);
if(a[i][j]=='@')//起点;
{
x=i;
y=j;
}
}
}
dfs(x,y);
printf("%d\n",res);
}
return 0;
}

这个省时好用,0ms;

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char a[24][24];
int res,n,m;
int mov[4][2]={1,0,-1,0,0,-1,0,1};//优化移动用法;
void dfs(int x,int y)
{
a[x][y]='#';
for(int i=0;i<4;i++)
{
int nx=x+mov[i][0];
int ny=y+mov[i][1];
if(1<=nx && nx<=m && 1<=ny && ny<=n && a[nx][ny]=='.')
{
res++;
dfs(nx,ny);
}
}
}
int main()
{
int p1,p2,i,j;
while(scanf("%d %d",&n,&m) && (m+n))
{
memset(a,0,sizeof(a));
res=1;
for(i=1;i<=m;i++)
{
getchar();
for(j=1;j<=n;j++)
{
scanf("%c",&a[i][j]);
if(a[i][j]=='@')
{
p1=i;
p2=j;
}
}
}
dfs(p1,p2);
printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: