您的位置:首页 > 理论基础 > 数据结构算法

1025. PAT Ranking (25)

2016-12-26 21:36 489 查看


1025. PAT Ranking (25)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after
the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300),
the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their
registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

—————————————————————————————————————————————————————————————————————————————

题意:
        有n个考场,每个考场有若干数量的考生。给出各个考场中考生的准考证号和分数,将所有的考生按分数降序排序,并按顺序输出所有考生的准考证号、排名、考场号以及考场内排名。

思路:

定义结构体Student,保存准考证号、分数、考场号、考场内排名;
sort()函数排序;(分数降序;否则,考号升序)

参考1.
#include <iostream>
#include <algorithm>
using namespace std;

struct Student {  //学生结构体;
char id[15];
int score;
int location_number;
int local_rank;
}stu[30010];

bool cmp(Student a, Student b) {  //sort参数;
if (a.score != b.score)
return a.score > b.score;
else
return strcmp(a.id, b.id) < 0;
}

int main() {
int n, k, num = 0;  // n为考场数; k考场人数;num为总学生数;
cin >> n;
for (int i = 1; i <= n; i++) {
cin >> k;
for (int j = 0; j < k; j++) {
cin >> stu[num].id;
cin >> stu[num].score;
stu[num].location_number = i;
num++;  //总考生+1;
}
sort(stu + num - k, stu + num, cmp);  //本考场排序;
stu[num - k].local_rank = 1;
for (int j = num + k - 1; j < num; j++) {
if (stu[j].score == stu[j - 1].score)
stu[j].local_rank = stu[j - 1].local_rank;
else
stu[j].local_rank = j + 1 - (num - k);
}
}
cout << num << endl;
sort(stu, stu + num, cmp);  //所有考场排序;
int r = 1;  //  总排名;
for (int i = 0; i < num; i++) {
if (stu[i].score != stu[i - 1].score) {
r = i + 1;
}
cout << stu[i].id << ' ';
cout << r << ' ' << stu[i].location_number << ' ' << stu[i].local_rank << endl;
}
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息