您的位置:首页 > 其它

hdu 1059 Dividing(多重背包)

2016-12-25 16:53 246 查看
[align=left]Problem Description[/align]
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could
just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so
that each of them gets the same total value.

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets
of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

 

[align=left]Input[/align]
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described
by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

 

[align=left]Output[/align]
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

 

[align=left]Sample Input[/align]

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

 

[align=left]Sample Output[/align]

Collection #1:
Can't be divided.

Collection #2:
Can be divided.
题意:给你1,2,3,4,5,6这6个价值的数量,问你能不能平分,当然每个价值是不能拆分的。
思路:多重背包啊 (不太了解多重背包的话,请看这道例题http://blog.csdn.net/qqchanmingdexiaji/article/details/53842460)
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n;
int c[10]= {1,2,3,4,5,6},mi[10];
int dp[120005];
void Zp(int c,int w) {
    int i;
    for(i=n; i>=c; i--)
        dp[i]=max(dp[i],dp[i-c]+w);
}
void Cp(int c,int w) {
    int i;
    for(i=c; i<=n; i++)
        dp[i]=max(dp[i],dp[i-c]+w);
}
void Mp(int c,int w,int sum) {
    if(n<=c*sum) {
        Cp(c,w);
        return ;
    } else {
        int k=1;
        while(k<=sum) {
            Zp(k*c,k*w);
            sum-=k;
            k*=2;
        }
        Zp(sum*c,sum*w);
    }
}
int main() {
    int cas=1;
    int i;
    while(scanf("%d%d%d%d%d%d",&mi[0],&mi[1],&mi[2],&mi[3],&mi[4],&mi[5]) && mi[0]+mi[1]+mi[2]+mi[3]+mi[4]+mi[5]) {
        memset(dp,0,sizeof(dp));
        printf("Collection #%d:\n",cas);
        cas++;
        n=0;
        for(i=0; i<6; i++)
            n+=c[i]*mi[i];
        if(n%2!=0)
            printf("Can't be divided.\n\n");
        else {
            n/=2;
            for(i=0; i<6; i++)
                Mp(c[i],c[i],mi[i]);
            if(dp
==n)
                printf("Can be divided.\n\n");//输出也要注意
            else
                printf("Can't be divided.\n\n");
        }
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 动态规划 dp