您的位置:首页 > 其它

杭电OJ—— 1014 Uniform Generator

2016-12-24 10:39 323 查看
[align=left]Problem Description[/align]
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully
can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function.
Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

 

[align=left]Input[/align]
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

 

[align=left]Output[/align]
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in
column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each
output test set, your program should print exactly one blank line.

 

[align=left]Sample Input[/align]

3 5
15 20
63923 99999

 

[align=left]Sample Output[/align]

         3         5    Good Choice

15 20 Bad Choice

63923 99999 Good Choice

题目挺简单,模拟一遍即可,不需要用数组来存

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int step,mod;
while(scanf("%d%d",&step,&mod)!=EOF){
int seed=0;
int cnt=0;   //计算走了多少步
do{
cnt++;

seed=(seed+step)%mod;

}while(seed!=0);			//因为从0开始 所以如果等于0说明循环了

if(cnt==mod){				//如果相等,即全部遍历
printf("%10d%10d    Good Choice\n", step, mod);
}else{
printf("%10d%10d    Bad Choice\n",step,mod);
}
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: