您的位置:首页 > 其它

POJ-----1088---滑雪DP

2016-12-23 22:17 405 查看
滑雪

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 93921 Accepted: 35555
Description
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9


一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output
25

每个点上下左右搜索即可,算得上优化版的暴力,但归类是DP

按数值从小到大排序,然后依次上下左右搜索

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1e2+10;
int map[maxn][maxn], dp[maxn][maxn];
int mov[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};
int ans, n, m, T;
struct node{
int x, y, val;
bool operator < (const node& a) const{
return val < a.val;
}
}M[maxn*maxn];
void DP(){
for(int c = 0; c < T; c++){
int i, j, x, y;
x = M[c].x;
y = M[c].y;
for(int v = 0; v < 4; v++){
i = x + mov[v][0];
j = y + mov[v][1];
if(i >= 0 && i < n && j >= 0 && j < m && map[x][y] > map[i][j]) dp[x][y] = max(dp[i][j]+1, dp[x][y]);//开始是按小于号来比较的,后来发现不对,小于号比较的是下一顺位,若是不连续就会出错,只能用大于号来动态规划当前值
ans = max(ans, dp[x][y]);
}
}
}
int main(){
int t;
T = ans = 0;
scanf("%d%d", &n, &m);
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
scanf("%d", &map[i][j]);
dp[i][j] = 1;
M[T].x = i;
M[T].y = j;
M[T++].val = map[i][j];
}
}
sort(M, M+T);
DP();
printf("%d\n", ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: