您的位置:首页 > 其它

华中农大HZAUOJ 1098 Yifan and War3 区间dp

2016-12-23 21:44 323 查看


1098: Yifan and War3

Time Limit: 3 Sec Memory Limit: 128 MB

Submit: 637 Solved: 23

[Submit][Status][Web
Board]


Description

As we all know, There is a hero called Priestess of the Moon(POM), which has a passive ability
named Trueshot Aura . It can add other units some ranged attacks . Fanfan love the Human very
much, and he will battle with a Night Elf everyday , because he thinks the Night Elf can’t attack his tower easily .But today , he met a Night Elf player , who use POM as his first hero, and had lots of Archers . Fanfan use theMountain
King to kill the Archers ,and don’t know how many health he need to kill all the Archers .Could you help him ?
To make the problem simple , we assume that all the Archers stand in a line , they have different attacks , if Fanfan kills the ith Archer , the (i+1)th and the (i-1)th Archer will help to attack Fanan by their own
attacks . There are N Archers , and Fanfan wants to know the least damage he will get to kill all the Archers .


Input

First line contains an integer N (0<N<200), means there are N Archers .
Then the next line contains N integers ai(0<ai<100000) means that the ith Archers have ai attacks .


Output

An integer means the least damage Fanfan will get.


Sample Input

3
10 100 10


Sample Output

150


HINT

Yifan first kill the second Archer , get 100+10+10 demages , and then kill the first one ,get 10+10 demages and finally kill the third one and get 10 demages so
, he get 150 demage

由于是原题,无耻地抢下了一血成功把榜带歪。。。。。

详细见hdu5115的题解

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 300;
int basic[maxn],extra[maxn];
int dp[maxn][maxn];
int main(){
int t,n,i,j,k,len;
while(~scanf("%d",&n)){
for(i=1;i<=n;i++){
scanf("%d",&basic[i]);
extra[i] = basic[i];
}
basic[0] = 0,basic[n+1] = 0;
extra[0] = 0,extra[n+1] = 0;
memset(dp, 0, sizeof(dp));
for(i=1;i<=n;i++){
for(j=i;j<=n;j++){
dp[i][j]=INF;
}
}
for(len=1;len<=n;len++){
for(i=1;i<=n-len+1;i++){
int j = i+len-1;
for(k=i;k<=j;k++){
dp[i][j] = min(dp[i][j],dp[i][k-1]+dp[k+1][j]+basic[k]+extra[i-1]+extra[j+1]);
}
}
}
printf("%d\n",dp[1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: