您的位置:首页 > 其它

poj Catch That Cow(BFS)

2016-12-23 16:57 211 查看
 Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
思路:
直接BFS枚举三种情况就好了。。。
代码:
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int a[200010],vis[200010];//小心re,*2可能会使数组超过10w
struct node
{
int x,step;
};
int bfs(int n,int k)
{
node now,next;
queue<node>q;
now.x=n,now.step=0;
q.push(now);
while(!q.empty())
{
now=q.front();
if(now.x==k)
return now.step;
if(now.x>0&&!vis[now.x-1])
{
next.x=now.x-1,next.step=now.step+1;
vis[next.x]=1;
q.push(next);
}
if(now.x<k&&!vis[now.x+1])
{
next.x=now.x+1,next.step=now.step+1;
vis[next.x]=1;
q.push(next);
}
if(now.x<k&&!vis[now.x*2])
{
next.x=now.x*2,next.step=now.step+1;
vis[next.x]=1;
q.push(next);
}
q.pop();
}
}
int main()
{
int n,k;
scanf("%d%d",&n,&k);
vis
=1;
int m=bfs(n,k);
printf("%d\n",m);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: