您的位置:首页 > 编程语言 > C语言/C++

poj1002

2016-12-23 13:59 399 查看
这题主要是对字符串进行操作

我用的是两个动态数组,可以得出正确结果,却超时。

先做个记录,之后修改好了,会继续发上来的。

原题

Description
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP.
Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could
order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers
in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number
appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output
310-1010 2
487-3279 4
888-4567 3


//原代码如下

#include <iostream>

#include <vector>

#include <string>

using namespace std;

string alter(string str){

    string s1=str;

    string s2="";

    int i=0;

    while(s1[i]!='\0'){

        if(s1[i]=='-'){

            ++i;

            continue;

        }else if('2'==s1[i]||'A'==s1[i]||'B'==s1[i]||'C'==s1[i]){

            s2+='2';

        }else if('3'==s1[i]||'D'==s1[i]||'F'==s1[i]||'E'==s1[i]){

            s2+='3';

        }else if('4'==s1[i]||'G'==s1[i]||'H'==s1[i]||'I'==s1[i]){

            s2+='4';

        }else if('5'==s1[i]||'J'==s1[i]||'K'==s1[i]||'L'==s1[i]){

            s2+='5';

        }else if('6'==s1[i]||'M'==s1[i]||'N'==s1[i]||'O'==s1[i]){

            s2+='6';

        }else if('7'==s1[i]||'P'==s1[i]||'R'==s1[i]||'S'==s1[i]){

            s2+='7';

        }else if('8'==s1[i]||'T'==s1[i]||'U'==s1[i]||'V'==s1[i]){

            s2+='8';

        }else if('9'==s1[i]||'W'==s1[i]||'X'==s1[i]||'Y'==s1[i]){

            s2+='9';

        }else if('0'==s1[i]){

            s2+='0';

        }else if('1'==s1[i]){

            s2+='1';

        }else {

            ++i;

            continue;

        }

        ++i;    

    }

    s2+='-';

    char temp=s2[s2.size()-1];

    for(int n=s2.size()-1;n>=3;--n){

        if(3==n){

            s2
=temp;

        }else{

            s2
=s2[n-1];

        }

    }

    return s2;

}

int main(){

    int n;

    string str1;

    string str2;

    bool flag=true;

    vector<string>input;

    vector<string>output;

    vector<int>count;

    cin>>n;

    for(int i=0;i<n;++i){

        count.push_back(0);

        cin>>str1;

        input.push_back(str1);

        str2=alter(str1);

        for(int j=0;j<output.size();++j){

            if(str2==output[j]){

                flag=false;

                count[j]++;

            }

        }

        if(flag){

            output.push_back(str2);

            count[output.size()-1]=1;

        }

        flag=true;

    }

    string strtemp;

    int itemp;

    for(int i=0;i<output.size();++i){

        for(int j=i;j<output.size();++j){

            if(output[i]>output[j]){

                strtemp=output[i];

                output[i]=output[j];

                output[j]=strtemp;

                itemp=count[i];

                count[i]=count[j];

                count[j]=itemp;

            }

        }

    }

    for(int k=0;k<output.size();++k){

        if(1==count[k]){

            continue;

        }

        cout<<output[k]<<" "<<count[k]<<endl;

    }

    

    

    

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法 c++