您的位置:首页 > 其它

poj 1195(二维树状数组)

2016-12-22 10:17 148 查看
Language:
Default

Mobile phones

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 18771 Accepted: 8661
Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The
number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with
the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter
integers according to the following table. 



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 

Cell value V at any time: 0 <= V <= 32767 

Update amount: -32768 <= A <= 32767 

No of instructions in input: 3 <= U <= 60002 

Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3

Sample Output
3
4

题意:在一个N*N的矩阵内,求一个子矩阵的和,而且可以随意增加单个位置的值。

解法有两种,
第一种是:二维树状数组
第二种是:二维线段树

我只会二维树状数组,并且这道题用二维树状数组写也十分方便。写的时候要注意下标不能为0。

某个位置的值增加很简单,求某个子矩阵的和,有个公式,比如这道题的公式就是:sum(B,T)- sum(L-1,T)- sum(B,R-1) + sum(L-1,R-1);

sum(B,T)函数求得是矩阵 (1<=x<=B,1<=y<=T )的和。看不懂公式的话自己画个图就明白了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define LL long long
#define MAXN 20000
using namespace std;
LL m[1100][1100],n;
LL lowbit(int k){
return k&(-k);
}
void add(int x,int y,int k){
for(int i=x;i<=n;i+=lowbit(i)){
for(int j=y;j<=n;j+=lowbit(j)){
m[i][j]+=k;
}
}
}
LL sum(int x,int y){
LL ans=0;
for(int i=x;i>=1;i-=lowbit(i)){
for(int j=y;j>=1;j-=lowbit(j)){
ans+=m[i][j];
}
}
return ans;
}
int main(){
int x,y,x1,y1,c;
while(scanf("%d",&c)){
if(c==0){
scanf("%d",&n);
}
else if(c==1){
scanf("%d%d%d",&x,&y,&x1);
add(x+1,y+1,x1);
}
else if(c==2){
scanf("%d%d%d%d",&x,&y,&x1,&y1);
printf("%lld\n",sum(x1+1,y1+1)-sum(x,y1+1)-sum(x1+1,y)+sum(x,y));
}
else break;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: