您的位置:首页 > 其它

POJ-3278 Catch the cow(BFS)

2016-12-21 16:55 288 查看
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point
N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point
K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or
X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and
K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
const int maxx=1000010;

queue<int> bfs_q;//bfs的队列
long long n,k;
bool visit[2*maxx]; //设定访问数组记录该点是否访问过
int step[maxx];//记录访问到该点时的步数

int BFS(){
bfs_q.push(n); //首元素压入队列
step
=0;
visit
=true;
while(!bfs_q.empty()){
long long head,next;
head=bfs_q.front(); //每次从头取数 取完就pop掉...
bfs_q.pop();
for(int i=-1;i<=1;i++){ //每次有三个状态
if(i==-1) next=head-1;
else if(i==0) next=head+1;
else next=head*2;
if(next<0||next>maxx) continue; //越界处理
if(!visit[next]){ //如果该点没有被访问过
bfs_q.push(next); //把该点压入队列
visit[next]=true; //标记为已访问
step[next]=step[head]+1;
}
if(next==k){
return step[next];
}
}
}
}
int main(){
scanf("%lld %lld",&n,&k);
memset(visit,false,sizeof(bool));
memset(step,0,sizeof(int));
if(n>=k){
printf("%d\n",n-k); //如果人在牛前面...直接...
}
else{
printf("%d\n",BFS());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: