您的位置:首页 > 其它

poj_1222 EXTENDED LIGHTS OUT(高斯消元解异或方程组)

2016-12-20 22:14 344 查看
EXTENDED LIGHTS OUT

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9773 Accepted: 6339
Description
In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four)
neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other
buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.



The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance,
in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.



Note:

1. It does not matter what order the buttons are pressed.

2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.

3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first

four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.

Write a program to solve the puzzle.
Input
The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off,
while a 1 indicates that the light is on initially.
Output
For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case,
1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.
Sample Input
2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output
PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1


开灯问题与高斯消元的结合。

由于位置一共只有30个,所以不用数组,用一个32位整数来表示矩阵的一行也可以。

对了,第一次知道 & 的优先级比 == 还低,吃个教训。


//数组版
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define FOP2 freopen("data1.txt","w",stdout)
#define inf 0x3f3f3f3f
#define maxn 1000010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int a[32][32];
typedef int Matrix[32][32];
int x[32];

Matrix A;

//equ个方程,var个变元 A[r][c], 0<r<equ, 0<c<var
int gauss_elimination(Matrix A, int equ, int var)
{
memset(x, 0, sizeof(x));
int row, col; //当前处理的行row和列col
int max_r;
for(row = 0, col = 0; row < equ && col < var; row++, col++)
{
if(A[row][col] == 0)
{
for(int r = row+1; r < equ; r++)
if(A[r][col])
{
for(int c = 0; c <= var; c++) swap(A[row][c],A[r][c]);
break;
}
}

//与第row+1~equ行进行消元
if(A[row][col])
for(int r = row+1; r < equ; r++)
{
if(A[r][col] == 0) continue;

for(int c = col; c <= var; c++)
{
A[r][c] ^= A[row][c];
}
}
}

int temp;
for (int r = var - 1; r >= 0; r--)
{
temp = A[r][var];
for(int c = r + 1; c < var; c++)
{
temp ^= x[c] * A[r][c];
}
x[r] = temp;
}
return 0;
}

int main()
{
for(int i = 0; i < 30; i++)
{
a[i][i] = 1;
if(i-1 >= i/6*6) a[i][i-1] = 1;
if(i+1 < 6+i/6*6) a[i][i+1] = 1;
if(i-6 >= 0) a[i][i-6] = 1;
if(i+6 < 30) a[i][i+6] = 1;
}

int T;
while(~scanf("%d", &T))
for(int casen = 1; casen <= T; casen++)
{
for(int i = 0; i < 30; i++)
{
for(int j = 0; j < 30; j++) A[i][j] = a[i][j];
}
int t;
for(int i = 0; i < 30; i++)
{
scanf("%d", &t);
A[i][30] = t;
}

gauss_elimination(A, 30, 30);

printf("PUZZLE #%d\n", casen);
for(int i = 0; i < 30; i++)
{
printf("%d", x[i]);
printf((i+1)%6 ? " " : "\n");
}
}
return 0;
}


//整数 版
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define FOP2 freopen("data1.txt","w",stdout)
#define inf 0x3f3f3f3f
#define maxn 1000010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int a[32];
int A[32];

//equ个方程,var个变元 A[r][c], 0<r<equ, 0<c<var
int gauss_elimination(int equ, int var)
{
int row, col; //当前处理的行row和列col
for(row = 0, col = 0; row < equ && col < var; row++, col++)
{
if((A[row] & (1<<col)) == 0)
{
for(int r = row+1; r < equ; r++)
if(A[r] & (1<<col))
{
swap(A[row],A[r]);
break;
}
}

//与第row+1~equ行进行消元
if(A[row] & (1<<col))
for(int r = 0; r < equ; r++)
{
if((A[r] & (1<<col)) == 0 || row == r) continue;
A[r] ^= A[row];
}
}
return 0;
}

int main()
{
for(int i = 0; i < 30; i++)
{
a[i] = 1<<i;
if(i-1 >= i/6*6) a[i] |= 1<<(i-1);
if(i+1 < 6+i/6*6) a[i] |= 1<<(i+1);
if(i-6 >= 0) a[i] |= 1<<(i-6);
if(i+6 < 30) a[i] |= 1<<(i+6);
}

int T;
scanf("%d", &T);
for(int casen = 1; casen <= T; casen++)
{
for(int i = 0; i < 30; i++) A[i] = a[i];

int t;
for(int i = 0; i < 30; i++)
{
scanf("%d", &t);
if(t) A[i] |= 1<<30;
}
gauss_elimination(30, 30);

printf("PUZZLE #%d\n", casen);
for(int i = 0; i < 30; i++)
{
printf("%d", A[i]>>30);
printf((i+1)%6 ? " " : "\n");
}
}
return 0;
}


4000
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: