您的位置:首页 > 其它

hdu1851 A Simple Game

2016-12-20 13:40 260 查看


A Simple Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/65535 K (Java/Others)

Total Submission(s): 1478    Accepted Submission(s): 933


Problem Description

Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M1 stones, the 2nd pile has M2 stones, ... and the n-th pile contain Mn stones.
Agrael and Animal take turns to move and in each move each of the players can take at most L1stones from the 1st pile or take at most L2 stones from the 2nd pile or ... or take Ln stones from the n-th pile. The player who takes
the last stone wins.

After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he
won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?
<script charset="Shift_JIS" src="http://chabudai.sakura.ne.jp/blogparts/honehoneclock/honehone_clock_tr.js"></script>


The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.

 

Input

The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers Mi and Li (20 ≥ Mi > 0, 20 ≥
Li > 0). 

 

Output

Your program output one line per case, if Agrael can win the game print "Yes", else print "No". 

 

Sample Input

2
1
5 4
2
1 1
2 2

 

Sample Output

Yes
No

 

Author

Agreal@TJU

 

Source

HDU 2007 Programming Contest - Final

 
题目大意:n堆石子,分别有M1,M2,...Mn个石子,各堆分别最多取L1,L2,...Ln个石头,两个人分别取,一次只能从一堆中取,取走最后一个石子的人获胜。
输入:第一行一个数字表示数据有多少组,每组测试数据第一行是一个整数n,表示有n行,然后n行分别是两个整数Mi,Li. 表示第i堆有Mi个石子,一次最多拿走Li个石子。
输出:后选的人获胜输出Yes,否则输出No。

巴什博弈(一堆博弈),只要n不能整除m+1,必然是先手胜。

#include<cstdio>
#include<cstdlib>

int n,m,l,ans;

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
ans=0;
for(int i=1;i<=n;i++)
{
scanf("%d %d",&m,&l);
int t=m%(l+1);
ans^=t;
}
if(ans) printf("No\n");
else printf("Yes\n");
}
return 0;
}

<script charset="Shift_JIS" src="http://chabudai.sakura.ne.jp/blogparts/honehoneclock/honehone_clock_tr.js"></script>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: