您的位置:首页 > 运维架构

Diophantus of Alexandria[HDU1299]

2016-12-16 13:56 148 查看
Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3242 Accepted Submission(s): 1287

Problem Description
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation:

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)

Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4

Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?

Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line.

Sample Input
2
4
1260

Sample Output
Scenario #1:
3

Scenario #2:
113

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<bitset>
#include<iomanip>

using namespace std;

#define MAX_PRIME 31700
#define PRIME_NUM 3500

int Primes[ PRIME_NUM + 10 ] ;

int _Count = 0  ;
int GetPrimes( )
{
unsigned char  *PrimeBuffer = ( unsigned char * ) malloc( sizeof( unsigned char ) * ( MAX_PRIME + 10 ) ) ;
int i , j  ;

memset( Primes , 0 , sizeof( int ) *PRIME_NUM ) ;
memset( PrimeBuffer , 0 , sizeof( unsigned char) * MAX_PRIME ) ;

for( i = 2 ; i < MAX_PRIME ; i++ )
{
if( PrimeBuffer[ i ] == 0 )
Primes[ _Count++ ] = i ;
for( j = 0 ; j < _Count && i * Primes[ j ] <= MAX_PRIME ; j++ )
{
PrimeBuffer[ i * Primes[ j ] ] = 1 ;
if( i % Primes[ j ] == 0 )
break ;
}
}
free( PrimeBuffer ) ;
return _Count ;
}

int main()
{
GetPrimes();
int Case , n , num , sum , temp;
cin >> Case ;
temp = 0 ;
while( Case-- )
{
cin >> n ;
sum = 1 ;
for( int i = 0 ; i < _Count ; ++i )
{
int  flag =  ( int )sqrt( n ) + 1 ;
if( Primes[ i ] > flag )
break ;
num = 0 ;
while( n % Primes[ i ] == 0 )
{
num++ ;
n /= Primes[ i ] ;
}
sum *= ( 1 + 2 * num ) ;
}
if( n > 1 )
sum *= 3 ;
cout << "Scenario #" << ++temp << ":" << endl ;
cout << ( sum + 1 ) / 2 << endl << endl ;
}
return 0 ;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: