您的位置:首页 > 其它

POJ-2386 Lake Counting

2016-12-15 23:50 381 查看
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer
John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output
* Line 1: The number of ponds in Farmer John's field.

Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

问题:w视为水,在一个水作为中心的九宫格只要有W则认为这两个是相连的水洼...问有多少个水洼;

分析:深搜的练手...从随便一个W开始不停寻找它附近联通的w然后改成‘.’就行了...最后调用DFS的次数就是水洼数;

#include<cstdio>
#define Max_N 10010
#define Max_M 10010
int N,M;
char field[Max_N][Max_M+1];

void input(){

for(int i=0;i<N;i++){
for(int j=0;j<M;j++){
scanf("%c",&field[i][j]);
}
getchar();//这个要注意啊...是为了接受呢个\0?
}
}
void dfs(int x,int y){
//把当前点从W改成.
field[x][y]='.';

for(int dx=-1;dx<=1;dx++){
for(int dy=-1;dy<=1;dy++){
//向各个方向移动
int nx=x+dx,ny=y+dy;
//判断条件,看是否在范围内
if(0<=nx&&nx<N&&0<=ny&&ny<M&&field[nx][ny]=='W') df
9809
s(nx,ny);
}
}
}

void solve(){
int res=0;
for(int i=0;i<N;i++){
for(int j=0;j<M;j++){
if(field[i][j]=='W'){
dfs(i,j);
res++;
}
}
}
printf("%d\n",res);
}

int main(){
while(scanf("%d %d",&N,&M)!=EOF){
getchar();
input();
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: