您的位置:首页 > 其它

POJ 1742 Coins 单调队列多重背包

2016-12-15 22:06 387 查看
Description

People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10

1 2 4 2 1 1

2 5

1 4 2 1

0 0

Sample Output

8

4

Solution

只有一个时做01背包,总价值大于等于m时做完全背包,其他情况单调队列存f[k]==1的下标,只要队列有元素即可更新。

#include<cstdio>
#include<cstring>
using namespace std;
int n,m,a[105],c[105],f[100005],q[100005];
int main()
{
while(1)
{
scanf("%d%d",&n,&m);
if(!n) break;
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
for(int i=1;i<=n;i++)
scanf("%d",&c[i]);
memset(f,0,sizeof(f));
f[0]=1;
for(int i=1;i<=n;i++)
if(c[i]==0)
for(int j=m;j>=a[i];j--)
f[j]=f[j]|f[j-a[i]];
else if(a[i]*c[i]>=m)
for(int j=a[i];j<=m;j++)
f[j]=f[j]|f[j-a[i]];
else for(int j=0;j<a[i];j++)
{
int h=1,t=0;
for(int k=j;k<=m;k+=a[i])
{
while(h<=t&&k-q[h]>c[i]*a[i]) h++;
if(f[k]) q[++t]=k;
else if(h<=t) f[k]=1;
}
}
int ans=0;

4000
for(int i=1;i<=m;i++)
if(f[i]) ans++;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: