您的位置:首页 > 其它

ZCMU—1051

2016-12-15 17:03 162 查看

1051: Divide Chocolate

Time Limit: 1 Sec  Memory Limit: 128 MB

[Submit][Status][Web
Board]

Description

It is well known that Claire likes dessert very much, especially chocolate. But as a girl she also focuses on the intake of calories each day. To satisfy both of the two desires, Claire makes a decision
that each chocolate should be divided into several parts, and each time she will enjoy only one part of the chocolate. Obviously clever Claire can easily accomplish the division, but she is curious about how many ways there are to divide the chocolate.

To simplify this problem, the chocolate can be seen as a rectangular contains n*2 grids (see above). And for a legal division plan, each part contains one or more grids that are connected. We say
two grids are connected only if they share an edge with each other or they are both connected with a third grid that belongs to the same part. And please note, because of the amazing craft, each grid is different with others, so symmetrical division methods
should be seen as different.

Input

  First line of the input contains one integer indicates the number of test cases. For each case, there is a single line containing two integers n (1<=n<=1000) and k (1<=k<=2*n).n denotes the size
of the chocolate and k denotes the number of parts Claire wants to divide it into.

Output

For each case please print the answer (the number of different ways to divide the chocolate) module 100000007 in a
single line. 

Sample Input

2

2 1

5 2

Sample Output

1

45

【分析】

题意很简单,给你2*n的巧克力,让你分成m份,问有几种方案。
显然是个状态dp...而且很容易想到跟骨牌覆盖一样的dp,但是没有骨牌覆盖那么简单,因为骨牌覆盖固定了骨牌的模式,而这道题没有规定如何切....虽然状态转移比骨牌覆盖少。。。但是的确我一直处于算错状态

f[i][0][j]表示前i行已经出现了j份并且第i行的两格属于同一部分
f[i][1][j]表示前i行已经出现了j份并且第i行的两格不属于同一部分也就是被切开
状态转移有12个情况
f[i+1][0][j]=(f[i+1][0][j]+f[i][0][j]+f[i][1][j]*2)%mod;  

f[i+1][0][j+1]=(f[i+1][0][j+1]+f[i][0][j]+f[i][1][j])%mod;  

f[i+1][1][j]=(f[i+1][1][j]+f[i][1][j])%mod;  

f[i+1][1][j+1]=(f[i+1][1][j+1]+f[i][0][j]*2+f[i][1][j]*2)%mod;  

f[i+1][1][j+2]=(f[i+1][1][j+2]+f[i][0][j]+f[i][1][j])%mod;  

初始化f[1][1][2]=f[1][0][1]=1;  
很难的一题DP...嗯...至少对我来说比较难了
【代码】
#include <stdio.h>
#define mod 100000007
int f[1010][2][2020]={0};
int main()
{
f[1][1][2]=1;
f[1][0][1]=1;
for(int i=1;i<=1000;i++)
{
for(int j=1;j<=2*i;j++)
{
f[i+1][0][j]=(f[i+1][0][j]+f[i][0][j]+f[i][1][j]*2)%mod;
f[i+1][0][j+1]=(f[i+1][0][j+1]+f[i][0][j]+f[i][1][j])%mod;
f[i+1][1][j]=(f[i+1][1][j]+f[i][1][j])%mod;
f[i+1][1][j+1]=(f[i+1][1][j+1]+f[i][0][j]*2+f[i][1][j]*2)%mod;
f[i+1][1][j+2]=(f[i+1][1][j+2]+f[i][0][j]+f[i][1][j])%mod;
}
}
int pp;scanf("%d",&pp);
while(pp--)
{
int n,m;scanf("%d%d",&n,&m);
printf("%d\n",(f
[1][m]+f
[0][m])%mod);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: