您的位置:首页 > 其它

NYOJ927 The partial sum problem(深搜DFS)

2016-12-14 08:38 537 查看
题目:


The partial sum problem

时间限制:1000 ms  |  内存限制:65535 KB
难度:2

描述One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K. 

输入There are multiple test cases.

Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents A[i](-10^8≤A[i]≤10^8).The third line contains an integer K(-10^8≤K≤10^8).
输出If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15


样例输出
Of course,I can!
Sorry,I can't!


来源原创
上传者

代码:

深搜水题,和部分和问题一样,注释就不写了,应该都能水过~

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stack>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int a[1000];
int n,k;
bool dfs(int s,int sum)
{
if(s==n)return sum==k;
if(dfs(s+1,sum))return 1;
if(dfs(s+1,sum+a[s]))return 1;
return 0;
}
int main()
{
n=0;
while(~scanf("%d",&n))
{
for (int i = 0; i < n; i++)
scanf("%d",&a[i]);
scanf("%d",&k);
if (dfs(0,0))
printf("Of course,I can!\n");
else
printf("Sorry,I can't!\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: