您的位置:首页 > 其它

UVa 455-Periodic Strings

2016-12-13 09:33 387 查看
A character string is said to have period k if it can be formed by concatenating one or more repetitions

of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed

by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one

repetition of ”abcabcabcabc”).

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your

program will test followed by a blank line. Each test case will contain a single character string of up

to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are

separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2

/**
* UVa 455 Periodic Strings
* Author: qyf
* Last Modified: 2016.12.13
*/

#include<stdio.h>
#include<string.h>
#define N 85
int main()
{
int n,i,j;
int tag;
int first=1;
scanf("%d",&n);
while(n--)
{
char s
;
scanf("%s",s);
int length=strlen(s);
for(i=1;i<=length;i++)
{
if(length%i==0)
{
tag=1;
for(j=0;j+i<length&&tag;j++)
{
if(s[j]!=s[j+i])        tag=0;
}
if(tag==1) break;
}
}
if(first)
{
printf("%d\n",i);
first=0;
}
else        printf("\n%d\n",i);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: