您的位置:首页 > 编程语言 > Go语言

POJ-2262 Goldbach's Conjecture

2016-12-12 15:54 267 查看
Goldbach's Conjecture

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44425 Accepted: 16977
Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 

written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 

20 = 3 + 17 = 7 + 13. 

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 

Each test case consists of one even integer n with 6 <= n < 1000000. 

Input will be terminated by a value of 0 for n.
Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair
where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."
Sample Input
8
20
42
0

Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source

Ulm Local 1998

本题的意思是:

输入一个大于6小于1000000的偶数。

这个数可以被两个奇素数相加,表示为n = a + b。

输出n-a最大的那一组。

读错题好几次。。。。。。

AC代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
int prime(int a)
{
int b;
for(b=2;b<=sqrt(a);b++)
{
if(a%b==0)
{
return 0;
}
}
return a;
}
int main()
{
int m,n,i,j,h,t,s;
while(scanf("%d",&m)!=EOF)
{
if(m==0) break;
h=m/2;
for(i=3;i<=h;i+=2)
{
n=m-i;
t=prime(i);
s=prime(n);
if(t&&s) break;
}
printf("%d = %d + %d\n",m,i,n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: