您的位置:首页 > 其它

ID

2016-12-11 18:16 369 查看
C.ID 

Time Limit: 1000 MS Memory Limit: 1000000 K 

Total Submit: 1421 (405 users)  Total Accepted: 264 (247 users)  Special Judge: No  

 

Description 

It is very cold in Harbin in the winter, but it is pretty warm in the Zhengxin Building. Today is Saturday, Teacher ABG want to play a trick on the only one student called NWL because he didn’t finish the MOOC. 

At the beginning, every student is in the building. The teacher calls some students to sweep the snow on the playground out of the building, and sometimes he also call some students who are on the playground back to the building. At last, teacher ABG wants
to leave only one student, NWL, on the playground out of the building. It means that the teacher ABG calls NWL’s ID ODD times, but called other students’ ID EVEN times, maybe more than twice. Now give you the list describing the students’ ID which the teacher
called in order, please tell us NWL’s ID. 

 

Input 

The first line is an integer T, describes the number of tests. Then T tests. 

In each test, the first line is an integer N, describes the number of IDs on the list. 

Then followed N lines, each line contains an integer M, describes one ID on the list. 

 

Output 

T lines. Each line, an integer, the NWL’s ID. 

 

Sample Input 

3

3

1140310000

1140310000

1140310000

1

1140310002

5

1

2

2

2

2

 

Sample Output 

1140310000

1140310002

1

 

Hint 

1<=T<=10 

1<=N<=1,000,000 

1<=M<=1,159,999,999 

The sum of N in the input file is no more than 3,000,000, all the input are integers and correct.

题意:这道题的意思就是找到那一个唯一的出现次数为奇数的数。

题解:这道题有两道解法,一种就是一个一个找,当找到那个出现次数为奇数的数时,就跳出来并输出。另一种是用按位异或运算,s=s^n,其实就是将出现次数为偶数的那个数给消去,将那个出现次数为奇数的输出来。

 
#include<stdio.h>
int n,t,x,s;
int main()
{
scanf("%d",&t);
while(t--)
{
s=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&x);
s^=x;
}
printf("%d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: