您的位置:首页 > 其它

华东交通大学2016届新生选拔赛:1003 Vitya in the Countryside

2016-12-11 16:22 453 查看


Vitya in the Countryside


Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)


Total Submission(s) : 31   Accepted Submission(s) : 12


Font: Times New Roman | Verdana | Georgia


Font Size: ← →


Problem Description

Every summer Vitya comes to visit his grandmother in the countryside. This summer, he got a huge wart. Every grandma knows that one should treat warts when the moon goes down. Thus, Vitya has to catch the moment when the moon is down.

Moon cycle lasts 30 days. The size of the visible part of the moon (in Vitya's units) for each day is 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 14, 13, 12, 11, 10, 9, 8, 7, 6, 5, 4, 3, 2, 1, and then cycle repeats, thus after the second 1 again
goes 0.

As there is no internet in the countryside, Vitya has been watching the moon for n consecutive days and for each of these days he wrote down the size of the visible part of the moon. Help him find out whether the moon will be up or down next day, or this cannot
be determined by the data he has.


Input

The first line of the input contains a single integer n (1≤n≤?92) — the number of consecutive days Vitya was watching the size of the visible part of the moon.

The second line contains n integers ai (0≤ai≤15) — Vitya's records.

It's guaranteed that the input data is consistent.


Output

If Vitya can be sure that the size of visible part of the moon on day n?+?1 will be less than the size of the visible part on day n, then print "DOWN" at the only line of the output. If he might be sure that the size of the visible part will increase, then
print "UP". If it's impossible to determine what exactly will happen with the moon, print -1.


Sample Input

5
3 4 5 6 7
7
12 13 14 15 14 13 12
1
8



Sample Output

UP
DOWN
-1


代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cctype>
#include<cstdio>
#include<set>
#include<cmath>
#include<string>
using namespace std;

int main(){
int n;
int a[95];
while(~scanf("%d",&n)){
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
if(a
==0)
printf("UP\n");
else if(a
==15)
printf("DOWN\n");
else if(n==1 && a
!=15 && a
!=0)
printf("-1\n");
else if(a
>a[n-1])
printf("UP\n");
else if(a
<a[n-1])
printf("DOWN\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: