您的位置:首页 > 其它

ACdream 1196 KIDx's Pagination

2016-12-10 21:17 267 查看
One Day, KIDx developed a beautiful pagination for ACdream. Now, KIDx wants you to make another one.

The are n pages in total.

The current page is cur.

The max distance to current page you can display is d.



Here are some rules:

The cur page button is disabled.
If cur page is the first page, the button "<<" should be disabled.
If cur page is the last page, the button ">>" should be disabled.
If the button "x" is disabled, print "[x]"; else print "(x)".
You should not display the "..." button when there is no hidden page.
You can assume that the button "..." is always disabled.

Input
There are multiple cases.

Ease case contains three integers n, cur, d.
1 ≤ n ≤ 100.

1 ≤ cur ≤ n.

0 ≤ d ≤ n.
Output
For each test case, output one line containing "Case #x: " followed by the result of pagination.

Sample Input

10 5 2
10 1 2


Sample Output

Case #1: (<<)[...](3)(4)[5](6)(7)[...](>>)
Case #2: [<<][1](2)(3)[...](>>)


Hint

Case 1: 



Case 2: 



原题链接:KIDx's Pagination

认真看题的话,这题不难,挺循规蹈矩的!

来看代码:

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
int n,cur,d,tp,cnt = 0;
int i;
while(scanf("%d %d %d",&n,&cur,&d)!=EOF)
{
printf("Case #%d: ",++cnt);
if(cur != 1)
printf("(<<)");
else
printf("[<<]");
if(cur - d > 1)
printf("[...]");
if(cur - d < 1)
tp = 1;
else
tp = cur - d;
for(i = tp; i < cur && i >= 1; i++)
printf("(%d)",i);
printf("[%d]",cur);       //以cur为分水岭
for(i = cur + 1; i <= cur + d && i <= n; i++)
printf("(%d)",i);
if(cur + d < n)
printf("[...]");
if(cur != n)
printf("(>>)");
else
printf("[>>]");
puts("");  //这条语句等价于printf("\n");或者cout>>endl;
}
return 0;
}

题不难,代码也不难理解,只要认真耐心看完就能懂哦!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm