您的位置:首页 > 其它

PAT--1120. Friend Numbers (20)

2016-12-10 21:06 351 查看
link

Description

Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID’s among them. Note: a number is considered a friend of itself.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8

123 899 51 998 27 33 36 12

Sample Output:

4

3 6 9 26

题解

计算每个数的数位之和。。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#include <string>
#include <set>
using namespace std;

int n;
set<int> S;

int main()
{
#ifndef ONLINE_JUDGE
freopen("data.in", "r", stdin);
#endif

cin >> n;
for(int i = 0; i < n; ++i){
string t; cin >> t;
int id = 0;
for(int j = 0; j < t.length(); ++j) id += t[j] - '0';
S.insert(id);
}

cout << S.size() << endl;
int i = 0;
for(set<int>::iterator it = S.begin(); it != S.end(); ++it){
if(i++) cout << " ";
cout << *it;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat