您的位置:首页 > 产品设计 > UI/UE

Longest Ordered Subsequence(最长上升子序列)

2016-12-10 17:14 330 查看
Longest Ordered Subsequence
Description
A numeric sequence of ai is ordered if a1 < a2 < ... < aN.
Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2,
..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example,
sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8

Sample Output
4

代码如下
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <limits.h>
#include <iostream>
using namespace std;
#define N 1001
int a
;
int l
;
int main()
{
int i,n,j,max = 0;
cin>>n;
for( i =0 ; i<n; i++)
cin>>a[i];
memset(l,0,sizeof(l));
//    memset(r,0,sizeof(r));

l[0] =1;//最长上升子序列
for( i =1 ; i<n; i++)
{
l[i] =1;
for(j = 0 ; j<i; j++)
if(a[j]<a[i] && l[j] >=l[i])
l[i] = l[j] + 1;
}
//    r[n-1] =1;//最长下降子序列
//    for(i = n-2; i>=0; i--)
//    {
//        r[i] = 1;
//        for( j =n-1; j>i; j--)
//            if(a[i] > a[j] && r[i] <= r[j])
//                r[i] = r[j] +1;
//    }
for(i=0; i<n; i++)
if(l[i]>max)
max = l[i] ;
cout<<max<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: