您的位置:首页 > 其它

hdoj 1004 Let the Balloon Rise (map)

2016-12-06 18:02 369 查看


Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 112557    Accepted Submission(s): 43959


Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

 

Sample Output

red
pink

 

出现次数最多的颜色,map<string,int>;string颜色覆盖,int计数,迭代器遍历容器内容。

代码:

/*迭代器:iterator GOF给出的定义为:
提供一种方法访问一个容器(container)对象中各个元素,而又不需暴露该对象的内部细节。
从定义可见,迭代器模式是为容器而生。很明显,对容器对象的访问必然涉及到遍历算法。
*/
//用迭代器遍历map的内容
#include <iostream>
#include<cstdio>
#include<map>
#include<string>
using namespace std;

int main()
{
string s,ch;
int n;
map<string,int>m;
while(scanf("%d",&n),n)
{
m.clear();
for(int i=0;i<n;i++)
{
cin>>s;
m[s]++;
}
int maxn=0;
map<string,int>::iterator t;//迭代器
for(t=m.begin();t!=m.end();t++)//遍历
{
if(t->second>maxn)
{
maxn=t->second;
ch=t->first;
}
}
cout<<ch<<endl;//输出
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: